POJ1509 Glass Beads
? 解题记录 ? ? 后缀自动机 ?    2017-07-18 12:27:06    552    0    0

                                                     Glass Beads

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

        纪念第一个后缀自动机,撒花撒花。

        首先考虑,这是一个环形问题,可以将字符串复制一遍连接到原串之后。然后对新串建立自动机。

        这样就能通过沿着自动机字典序小的边走轻松找出为N的字典序最小的子串。达到目的。

        下面是一段丑陋的代码…………

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=2e4+100;
int trie[maxn*2][26],fail[maxn*2],len[maxn*2];
int num[maxn*2];
int cnt=1,last=1;//trie节点cnt 以及上一个状态节点 
//根节点为1 
char s[maxn];

void add(int x)   //SAM后缀自动机 
{
	int id=s[x]-'a';
	int p=last,np=++cnt;//创建新的主线节点 
	num[np]=x;
	last=np;//last记录的是父亲(上一个)节点 
	len[np]=x+1;
	while(p!=0 && !trie[p][id])//向上寻找重复串位置
	{
		trie[p][id]=np;//将不重复位置连边
		p=fail[p]; 
	}
	if(p==0)//跳出了自动机
		fail[np]=1;
	else
	{
		int q=trie[p][id];//q为p的下一个 
		if(len[p]+1==len[q])
			fail[np]=q;//如果可以直接顺序链接,只改变fail指针 
		else
			{
				int lca=++cnt;//如果分叉,开辟新节点保存 
				num[lca]=num[q];//复制节点 继承原节点的num 
				len[lca]=len[p]+1;
				memcpy(trie[lca],trie[q],sizeof(trie[q]));
				fail[lca]=fail[q];
				fail[q]=fail[np]=lca;
				while(p && trie[p][id]==q)
				{
					trie[p][id]=lca;
					p=fail[p];
				}
			}
	}
}

int main()
{
	int n;
	scanf("%d",&n);

	while(n--)
	{
		memset(trie,0,sizeof(trie));
		memset(fail,0,sizeof(fail));
		memset(len,0,sizeof(len));
		memset(num,0,sizeof(num));
		cnt=1;last=1;
		scanf("%s",s);
		char ns[maxn];
		int ol=strlen(s);
		memcpy(ns,s,sizeof(s));
		strcat(s,ns);
		int len=strlen(s);
		for(int i=0;i<len;i++)
			add(i);
		int now=1;
		for(int i=1;i<=ol;i++)
		{
			for(int j=0;j<26;j++)
				if(trie[now][j])
				{
					now=trie[now][j];
					break;
				}
		}
			printf("%d\n",num[now]-ol+2);
		
	}
	return 0;
}

 

上一篇: 洛谷 P1807 最长路

下一篇: 洛谷P3379 【模板】最近公共祖先(LCA)

552 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航