CF988E Divisibility by 25
? 解题记录 ? ? Codeforces ?    2018-06-09 09:33:50    369    0    0

题目描述

You are given an integer n from 11 to 10^{18} without leading zeroes.

In one move you can swap any two adjacent digits in the given number in such a way that the resulting number will not contain leading zeroes. In other words, after each move the number you have cannot contain any leading zeroes.

What is the minimum number of moves you have to make to obtain a number that is divisible by 25 ? Print -1 if it is impossible to obtain a number that is divisible by 25 .

输入输出格式

输入格式:

 

The first line contains an integer nn ( 1n1018 ). It is guaranteed that the first (left) digit of the number nn is not a zero.

 

输出格式:

 

If it is impossible to obtain a number that is divisible by 25 , print -1. Otherwise print the minimum number of moves required to obtain such number.

Note that you can swap only adjacent digits in the given number.

 

输入输出样例

输入样例#1: 复制
5071
输出样例#1: 复制
4
输入样例#2: 复制
705
输出样例#2: 复制
1
输入样例#3: 复制
1241367
输出样例#3: 复制
-1

说明

In the first example one of the possible sequences of moves is 5071  5701  7501  7510  7150.

本来水着div3多愉快,突然遇到这个细节题,本来觉得就是把末尾移成00\25\50\75,应该多水的结果被坑惨了。交了5遍才把细节都处理完,就挂上来。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char s[20];
int pos5, pos2, pos0, pos0_2, pos7, len, ans = 0x7fffffff;
int zeros, z1, z2;

int Gans(int x, int y, int z) {
	int lenx = len - 1 - x, leny = len - 1 - y;
	if(y == len - 1) leny = 0;
	if(x < y) lenx = len - 2 - x;
	if(x == 0 || y == 0) return lenx + leny + z;
	return lenx + leny;
}

int main() {
	pos5 = pos2 = pos0 = pos0_2 = pos7 = -1;
	scanf("%s", s);
	len = strlen(s);
	for(register int i = 1; i < len && s[i] == '0'; ++i) ++zeros;
	for(register int i = 0; i < len; ++i) {
		if(s[i] == '5') pos5 = i;
		if(s[i] == '7') pos7 = i;
		if(s[i] == '2') pos2 = i;
		if(s[i] == '0')
			if(pos0) pos0 = pos0_2, pos0_2 = i;
			else pos0 = i;
	}
	swap(pos0, pos0_2), z1 = zeros, z2 = zeros;
	if(~pos0_2 && pos0_2 <= zeros) --z1;
	if(~pos0 && pos0 <= zeros) --z2, --z1;
	if(~pos7 && ~pos5) ans = min(ans, Gans(pos7, pos5, zeros));
	if(~pos2 && ~pos5) ans = min(ans, Gans(pos2, pos5, zeros));
	if(~pos5 && ~pos0) ans = min(ans, Gans(pos5, pos0, z1));
	if(~pos0_2 && ~pos0) ans = min(ans, Gans(pos0_2, pos0, z2));
	printf("%d\n", ans == 0x7fffffff ? -1 : ans);
	return 0;
}


上一篇: 洛谷P3577 [POI2014]TUR-Tourism

下一篇: 为各位的博客提供雪花模板

369 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航