POJ1422 Air Raid
? 解题记录 ? ? POJ ? ? 二分图匹配 ?    2018-03-24 16:30:52    371    0    0

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles. 

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

no_of_intersections 
no_of_streets 
S1 E1 
S2 E2 
...... 
Sno_of_streets Eno_of_streets 

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

这道题就是求最小路径覆盖。最小路径覆盖是二分图匹配的基本模型。对于原图每一个点x,我们把它分为x1、x2。对于原图每一条边(u,v)我们连边:u1->v2。由于一条路径等价于该子图上每一个点出度和入度都为1。我们的构图相当于对于每一个点x,x1表示x有一个出度,x2表示x有一个入度。那么我们的一个匹配相当于为u1贡献了一个出度、为v2贡献了一个入度,并且一个点的出度入度最多为1。正确性是没有问题的。

#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#define L 0
#define R 1
using namespace std;
const int maxn = 1e5 + 5;
struct edge {
	int v, w, next;
}e[maxn];
int head[maxn], cnt, n, m, u, v, t;
void adde(const int &u, const int &v, const int &w) {
	e[cnt] = (edge) {v, w, head[u]};
	head[u] = cnt++;
	e[cnt] = (edge) {u, 0, head[v]};
	head[v] = cnt++;
}
int layer[maxn], p[maxn][2], pcnt, S, T;
bool bfs(int s, int t) {
	memset(layer, 0, sizeof(layer));
	queue<int > q;
	q.push(s), layer[s] = 1;
	while(!q.empty()) {
		int u = q.front();
		q.pop();
		for(register int i = head[u]; ~i; i = e[i].next) {
			int v = e[i].v;
			if(layer[v] || !e[i].w) continue;
			layer[v] = layer[u] + 1, q.push(v);
		}
	}
	return layer[t];
}
int dfs(int u, int t, int flow) {
	int ret, inc = 0;
	if(u == t) return flow;
	for(register int i = head[u]; ~i && flow - inc > 0; i = e[i].next) {
		int v = e[i].v;
		if(layer[v] != layer[u] + 1 || !e[i].w) continue;
		ret = dfs(v, t, min(flow - inc, e[i].w));
		if(ret) {
			e[i].w -= ret;
			e[i ^ 1].w += ret;
			inc += ret;
		}
	}
	return inc;
}
int dinic(int s, int t) {
	int ans = 0;
	while(bfs(s, t)) 
		ans += dfs(s, t, 0x3f3f3f3f);
	return ans;
}
int main() {
	scanf("%d", &t);
	while(t--) {
		memset(head, -1, sizeof(head)), cnt = 0;
		scanf("%d%d", &n, &m), S = pcnt = 1;
		for(register int i = 1; i <= n; ++i)
			p[i][0] = ++pcnt, p[i][1] = ++pcnt;
		for(register int i = 1; i <= m; ++i)
			scanf("%d%d", &u, &v), adde(p[u][L], p[v][R], 1);
		T = ++pcnt;
		for(register int i = 1; i <= n; ++i)
			adde(S, p[i][L], 1), adde(p[i][R], T, 1);
		printf("%d\n", n - dinic(S, T));
	}
}

 

上一篇: BZOJ3566: [SHOI2014]概率充电器

下一篇: BZOJ1143: [CTSC2008]祭祀river

371 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航