POJ3259 Wormholes
? 解题记录 ? ? POJ ? ? 补档计划第一期 ? ? 最短路 ?    2017-10-01 10:17:30    364    0    0
Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 55119 Accepted: 20556

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

 

其实这就是一道负权最短路,用SPFA跑即可。正常道路连双向边,遇到虫洞就连单向负权边。注意边集数组大小。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=6000;
const int maxm=600;
const int inf=0x3f3f3f3f;
struct edge
{
	int u,v,w;
	int next;
}e[maxn*2];

int head[maxm]={ };
bool vis[maxm]={ };
int dis[maxm]={ };
int n,m,w;
int cnt;
int org;
int inc[maxm]={ };

void adde(int u,int v,int w)
{
	e[++cnt].u=u;
	e[cnt].v=v;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt;
}

bool spfa()
{
	queue<int> q;
	dis[1]=0;
	q.push(1);
	vis[1]=1;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=e[i].next)
		{
			int v=e[i].v;
			if(dis[v]>dis[u]+e[i].w)
			{
				dis[v]=dis[u]+e[i].w;
				if(!vis[v])
				{
					inc[v]++;
					if(inc[v]>n)
						return false; 
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
	return true;
}

int main()
{
	int ccc;
	scanf("%d",&ccc);
	while(ccc--)
	{
		cnt=0;
		scanf("%d%d%d",&n,&m,&w);
		memset(inc,0,sizeof(inc));
		memset(dis,inf,sizeof(dis));
		memset(vis,0,sizeof(vis));
		memset(head,-1,sizeof(head));
			for(int i=1;i<=m;i++)
				{
					int a,b,c;
					scanf("%d%d%d",&a,&b,&c);
					adde(a,b,c);
					adde(b,a,c);
				}
			for(int i=1;i<=w;i++)
				{
					int a,b,c;
					scanf("%d%d%d",&a,&b,&c);
					adde(a,b,0-c);
				}
				
		bool reted=spfa();
		if(reted==1)
			printf("NO\n");
		else
			printf("YES\n");
	}
	return 0;
}

 

上一篇: POJ2774 Long Long Message

下一篇: 洛谷P1169 [ZJOI2007]棋盘制作

364 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航