HDU1704 Rank
? 解题记录 ? ? 传递闭包 ? ? HDU ?    2017-08-20 10:43:10    310    0    0

Rank

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1739    Accepted Submission(s): 678


Problem Description
there are N ACMers in HDU team.
ZJPCPC Sunny Cup 2007 is coming, and lcy want to select some excellent ACMers to attend the contest. There have been M matches since the last few days(No two ACMers will meet each other at two matches, means between two ACMers there will be at most one match). lcy also asks"Who is the winner between A and B?" But sometimes you can't answer lcy's query, for example, there are 3 people, named A, B, C.and 1 match was held between A and B, in the match A is the winner, then if lcy asks "Who is the winner between A and B", of course you can answer "A", but if lcy ask "Who is the winner between A and C", you can't tell him the answer.
As lcy's assistant, you want to know how many queries at most you can't tell lcy(ask A B, and ask B A is the same; and lcy won't ask the same question twice).
 


Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
Each case first contains two integers N and M(N , M <= 500), N is the number of ACMers in HDU team, and M is the number of matchs have been held.The following M lines, each line means a match and it contains two integers A and B, means A wins the match between A and B.And we define that if A wins B, and B wins C, then A wins C.
 


Output
For each test case, output a integer which represent the max possible number of queries that you can't tell lcy.
 


Sample Input
3
3 3
1 2
1 3
2 3
3 2
1 2
2 3
4 2
1 2
3 4
 


Sample Output
0
0
4Hint
in the case3, if lcy ask (1 3 or 3 1) (1 4 or 4 1) (2 3 or 3 2) (2 4 or 4 2), then you can't tell him who is the winner.
 

Source
 

Floyd中间点先枚举

一个传递闭包的题,推荐这一篇博客:http://www.cnblogs.com/lpshou/archive/2012/04/27/2473109.html

 

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 550;
int n, m, u, v, cnt;
int map[maxn][maxn];

inline int read() {
	int ret = 0;
	char c = getchar();
	while(c > '9' || c < '0') c = getchar();
	while(c >= '0' && c <= '9') ret = ret * 10 + c - '0', c = getchar();
	return ret;
}

int main() {
	int t;
	scanf("%d", &t);
	while(t--) {
		cnt = 0;
		memset(map, 0, sizeof(map));
		n = read(), m = read();
		while(m--) {
			u = read(), v = read();
			map[u][v] = 1;
		}
		for(register int j = 1; j <= n; ++j)
			for(register int i = 1; i <= n; ++i) 
				if(map[i][j])
					for(register int k = 1; k <= n; ++k) 
						if(map[j][k])
							map[i][k] = 1;
		for(register int i = 1; i < n; ++i) 
			for(register int j = i+1; j <= n; ++j)
				if(!(map[i][j] || map[j][i]))++cnt;
		printf("%d\n", cnt);
	}
	return 0;
}
 

 

上一篇: 洛谷 P2680 运输计划

下一篇: POJ1741 Tree

310 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航